Home > Apache | Python | サーバ構築 > mod_wsgiをコンパイルする

mod_wsgiをコンパイルする

コレを書いているのは2010/11/05です。その当時のメモです。一応。
aptitudeとかでいれても、2.6.5向けのコンパイルだから云々ってapacheのログに出るわけです。

[warn] mod_wsgi: Compiled for Python/2.6.5.
[warn] mod_wsgi: Runtime using Python/2.6.6.

きもいので解消するの巻。
mod_wsgi-3.3.tar.gzを拾ってきます。
いつもどおりtar zxfvで開いて
./configure –with-python=/usr/bin/python2.6
apxs云々いわれたらapache-devだかそのへんのを入れよう。多分はいってる。
ついでにpython-devもいれよう。
ほんでmake
make installとかそんなんだ。

[notice] Apache/2.2.16 (Ubuntu) 
PHP/5.3.3-1ubuntu9.1 with Suhosin-Patch 
mod_wsgi/3.2 Python/2.6.6 configured 
-- resuming normal operations

ログ見たらコレで出なくなってた。なーんでかpython2.7ではこの手順がうまく行かなかったのが無念。なんでだろ。

modのリコンパイルとかしたあとはreloadじゃだめで、restartでちゃんと動いた気がする。気がするだけですが。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

Trackbacks:0

Listed below are links to weblogs that reference
mod_wsgiをコンパイルする from くちなわのしょ::おねーさんブログ分室
TOP